summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index ffa28cfdba..446c7891f2 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,18 @@
+[tool.black]
+line-length = 99
+target-version = ['py27', 'py35', 'py36', 'py37', 'py38', 'py39', 'py310']
+include = '''
+ \.pyi?$
+'''
+extend-exclude = '''
+/(
+ \.git
+ | \.mypy_cache
+ | ^lib/spack/external/
+ | ^opt/
+)/
+'''
+
[tool.isort]
profile = "black"
sections = [