summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/fast-global-file-status/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/fast-global-file-status/package.py')
-rw-r--r--var/spack/repos/builtin/packages/fast-global-file-status/package.py47
1 files changed, 47 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/fast-global-file-status/package.py b/var/spack/repos/builtin/packages/fast-global-file-status/package.py
new file mode 100644
index 0000000000..186f7a8e98
--- /dev/null
+++ b/var/spack/repos/builtin/packages/fast-global-file-status/package.py
@@ -0,0 +1,47 @@
+##############################################################################
+# Copyright (c) 2013-2018, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/spack/spack
+# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class FastGlobalFileStatus(AutotoolsPackage):
+ """provides a scalable mechanism to retrieve such information of a file,
+ including its degree of distribution or replication and consistency."""
+
+ homepage = "https://github.com/LLNL/FastGlobalFileStatus"
+ url = 'https://github.com/LLNL/FastGlobalFileStatus/files/2271592/fastglobalfilestatus-1.1.tar.gz'
+
+ version('1.1', 'c3d764c47a60310823947c489cd0f2df')
+
+ depends_on('mrnet')
+ depends_on('mount-point-attributes')
+ depends_on('mpi')
+
+ def configure_args(self):
+ spec = self.spec
+ args = [
+ "--with-mpa=%s" % spec['mount-point-attributes'].prefix,
+ "--with-mrnet=%s" % spec['mrnet'].prefix
+ ]
+ return args