summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/git/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/git/package.py')
-rw-r--r--var/spack/repos/builtin/packages/git/package.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/var/spack/repos/builtin/packages/git/package.py b/var/spack/repos/builtin/packages/git/package.py
index 3dfe1d6cc2..f122fdbb3d 100644
--- a/var/spack/repos/builtin/packages/git/package.py
+++ b/var/spack/repos/builtin/packages/git/package.py
@@ -278,12 +278,8 @@ class Git(AutotoolsPackage):
"--with-zlib={0}".format(spec["zlib-api"].prefix),
]
- if not self.spec["iconv"].name == "libc":
- configure_args.append(
- "--with-iconv={0}".format(
- "yes" if is_system_path(spec["iconv"].prefix) else spec["iconv"].prefix
- )
- )
+ if self.spec["iconv"].name == "libiconv":
+ configure_args.append(f"--with-iconv={self.spec['iconv'].prefix}")
if "+perl" in self.spec:
configure_args.append("--with-perl={0}".format(spec["perl"].command.path))