summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/hcoll/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/hcoll/package.py')
-rw-r--r--var/spack/repos/builtin/packages/hcoll/package.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/hcoll/package.py b/var/spack/repos/builtin/packages/hcoll/package.py
new file mode 100644
index 0000000000..f39e2e7596
--- /dev/null
+++ b/var/spack/repos/builtin/packages/hcoll/package.py
@@ -0,0 +1,31 @@
+# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Hcoll(Package):
+ """Modern interface for Mellanox Fabric Collective Accelerator (FCA). FCA
+ is a MPI-integrated software package that utilizes CORE-Direct technology
+ for implementing the MPI collective communications."""
+
+ homepage = 'https://www.mellanox.com/products/fca'
+ has_code = False
+
+ version('3.9.1927')
+
+ # HCOLL needs to be added as an external package to SPACK. For this, the
+ # config file packages.yaml needs to be adjusted:
+ #
+ # hcoll:
+ # version: [3.9.1927]
+ # paths:
+ # hcoll@3.9.1927: /opt/mellanox/hcoll (path to your HCOLL installation)
+ # buildable: False
+
+ def install(self, spec, prefix):
+ raise InstallError(
+ self.spec.format('{name} is not installable, you need to specify '
+ 'it as an external package in packages.yaml'))