summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/icu4c/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/icu4c/package.py')
-rw-r--r--var/spack/repos/builtin/packages/icu4c/package.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/icu4c/package.py b/var/spack/repos/builtin/packages/icu4c/package.py
index 39523b1563..e6a3df465d 100644
--- a/var/spack/repos/builtin/packages/icu4c/package.py
+++ b/var/spack/repos/builtin/packages/icu4c/package.py
@@ -46,4 +46,11 @@ class Icu4c(AutotoolsPackage):
return url.format(version.dotted, version.underscored)
def configure_args(self):
- return ['--enable-rpath']
+ args = []
+
+ # The --enable-rpath option is only needed on MacOS, and it
+ # breaks the build for xerces-c on Linux.
+ if 'platform=darwin' in self.spec:
+ args.append('--enable-rpath')
+
+ return args