summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/mpi-bash/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/mpi-bash/package.py')
-rw-r--r--var/spack/repos/builtin/packages/mpi-bash/package.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/mpi-bash/package.py b/var/spack/repos/builtin/packages/mpi-bash/package.py
new file mode 100644
index 0000000000..5b3731fbbe
--- /dev/null
+++ b/var/spack/repos/builtin/packages/mpi-bash/package.py
@@ -0,0 +1,28 @@
+# Copyright 2013-2019 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class MpiBash(AutotoolsPackage):
+ """Parallel scripting right from the Bourne-Again Shell (Bash)"""
+
+ homepage = "https://github.com/lanl/MPI-Bash"
+ url = "https://github.com/lanl/MPI-Bash/releases/download/v1.2/mpibash-1.2.tar.gz"
+
+ version('1.2', sha256='5c2faaa74464111205dbae4799bd89c2425810ec3708d004237b42d620c8be57')
+
+ depends_on('bash@4.4:')
+ # uses MPI_Exscan which is in MPI-1.2 and later
+ depends_on('mpi@1.2:')
+
+ depends_on('libcircle')
+
+ def configure_args(self):
+ args = [
+ "--with-bashdir={0}".format(self.spec['bash'].prefix.include.bash),
+ "CC={0}".format(self.spec['mpi'].mpicc)
+ ]
+ return args