summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/portage/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/portage/package.py')
-rw-r--r--var/spack/repos/builtin/packages/portage/package.py8
1 files changed, 1 insertions, 7 deletions
diff --git a/var/spack/repos/builtin/packages/portage/package.py b/var/spack/repos/builtin/packages/portage/package.py
index 2bbc54b6cb..51166b97a3 100644
--- a/var/spack/repos/builtin/packages/portage/package.py
+++ b/var/spack/repos/builtin/packages/portage/package.py
@@ -34,7 +34,7 @@ class Portage(CMakePackage):
homepage = "http://portage.lanl.gov/"
url = "https://github.com/laristra/portage/tarball/v1.0"
- version('develop', git='https://github.com/laristra/portage', branch='master', submodules=False)
+ version('develop', git='https://github.com/laristra/portage', branch='master', submodules=True)
variant('debug', default=False, description='Build debug version')
variant('mpi', default=True, description='Support MPI')
@@ -42,12 +42,6 @@ class Portage(CMakePackage):
depends_on("cmake@3.1:", type='build')
depends_on('mpi', when='+mpi')
- # drop when #3958 has been merged
- def do_fetch(self, mirror_only=True):
- super(Portage, self).do_fetch(mirror_only)
- git = which("git")
- git('submodule', 'update', '--init', '--recursive')
-
def build_type(self):
spec = self.spec
if '+debug' in spec: