summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-csvkit/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-csvkit/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-csvkit/package.py20
1 files changed, 8 insertions, 12 deletions
diff --git a/var/spack/repos/builtin/packages/py-csvkit/package.py b/var/spack/repos/builtin/packages/py-csvkit/package.py
index 7fe2f953f7..5bcda9f449 100644
--- a/var/spack/repos/builtin/packages/py-csvkit/package.py
+++ b/var/spack/repos/builtin/packages/py-csvkit/package.py
@@ -24,7 +24,8 @@
##############################################################################
from spack import *
-class PyCsvkit(Package):
+
+class PyCsvkit(PythonPackage):
"""A library of utilities for working with CSV, the king of tabular file
formats"""
@@ -33,14 +34,9 @@ class PyCsvkit(Package):
version('0.9.1', '48d78920019d18846933ee969502fff6')
- extends('python')
-
- depends_on('py-dateutil')
- depends_on('py-dbf')
- depends_on('py-xlrd')
- depends_on('py-SQLAlchemy')
- depends_on('py-six')
- depends_on('py-openpyxl')
-
- def install(self, spec, prefix):
- python('setup.py', 'install', '--prefix=%s' % prefix)
+ depends_on('py-dateutil', type=('build', 'run'))
+ depends_on('py-dbf', type=('build', 'run'))
+ depends_on('py-xlrd', type=('build', 'run'))
+ depends_on('py-sqlalchemy', type=('build', 'run'))
+ depends_on('py-six', type=('build', 'run'))
+ depends_on('py-openpyxl', type=('build', 'run'))