summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-protobuf/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/py-protobuf/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-protobuf/package.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/var/spack/repos/builtin/packages/py-protobuf/package.py b/var/spack/repos/builtin/packages/py-protobuf/package.py
index 83ba3fd69c..da65d131a8 100644
--- a/var/spack/repos/builtin/packages/py-protobuf/package.py
+++ b/var/spack/repos/builtin/packages/py-protobuf/package.py
@@ -74,14 +74,9 @@ class PyProtobuf(PythonPackage):
env.prepend_path('LIBRARY_PATH', protobuf_dir)
@when('+cpp')
- def build_args(self, spec, prefix):
+ def install_options(self, spec, prefix):
return ['--cpp_implementation']
- @when('+cpp')
- def install_args(self, spec, prefix):
- args = super(PyProtobuf, self).install_args(spec, prefix)
- return args + ['--cpp_implementation']
-
@run_after('install')
def fix_import_error(self):
if str(self.spec['python'].version.up_to(1)) == '2':