summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/rocalution/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/rocalution/package.py')
-rw-r--r--var/spack/repos/builtin/packages/rocalution/package.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/var/spack/repos/builtin/packages/rocalution/package.py b/var/spack/repos/builtin/packages/rocalution/package.py
index 0213f61f8e..9753dbd371 100644
--- a/var/spack/repos/builtin/packages/rocalution/package.py
+++ b/var/spack/repos/builtin/packages/rocalution/package.py
@@ -18,12 +18,13 @@ class Rocalution(CMakePackage):
homepage = "https://github.com/ROCmSoftwarePlatform/rocALUTION"
git = "https://github.com/ROCmSoftwarePlatform/rocALUTION.git"
- url = "https://github.com/ROCmSoftwarePlatform/rocALUTION/archive/rocm-5.2.3.tar.gz"
+ url = "https://github.com/ROCmSoftwarePlatform/rocALUTION/archive/rocm-5.3.0.tar.gz"
tags = ["rocm"]
maintainers = ["cgmb", "srekolam", "renjithravindrankannath"]
libraries = ["librocalution_hip"]
+ version("5.3.0", sha256="f623449789a5c9c9137ae51d4dbbee5c6940d8813826629cb4b7e84f07fab494")
version("5.2.3", sha256="8e0d77099bf7dc0d00505e1c936b072a59719102c75398dc1416cbef31902253")
version("5.2.1", sha256="f246bd5b5d1b5821c29b566610a1c1d5c5cc361e0e5c373b8b04168b05e9b26f")
version("5.2.0", sha256="a5aac471bbec87d019ad7c6db779c73327ad40ecdea09dc5ab2106e62cd6b7eb")
@@ -131,6 +132,7 @@ class Rocalution(CMakePackage):
"5.2.0",
"5.2.1",
"5.2.3",
+ "5.3.0",
]:
depends_on("hip@" + ver, when="@" + ver)
depends_on("rocprim@" + ver, when="@" + ver)
@@ -163,6 +165,7 @@ class Rocalution(CMakePackage):
"5.2.0",
"5.2.1",
"5.2.3",
+ "5.3.0",
]:
for tgt in itertools.chain(["auto"], amdgpu_targets):
depends_on(
@@ -173,7 +176,7 @@ class Rocalution(CMakePackage):
depends_on("googletest@1.10.0:", type="test")
# This fix is added to address the compilation failure and it is
# already taken in 5.2.3 rocm release.
- patch("0003-fix-compilation-for-rocalution-5.2.0.patch", when="@5.2.0:")
+ patch("0003-fix-compilation-for-rocalution-5.2.0.patch", when="@5.2")
# Fix build for most Radeon 5000 and Radeon 6000 series GPUs.
patch("0004-fix-navi-1x.patch", when="@5.2.0:")
@@ -225,4 +228,7 @@ class Rocalution(CMakePackage):
if self.spec.satisfies("@5.2.0:"):
args.append(self.define("BUILD_FILE_REORG_BACKWARD_COMPATIBILITY", True))
+ if self.spec.satisfies("@5.3.0:"):
+ args.append("-DCMAKE_INSTALL_LIBDIR=lib")
+
return args