summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-23 22:18:34 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-23 22:18:34 -0500
commit2a46aec465207280f31dbe8031f420e8b9851ece (patch)
tree6d5a7ddeab97d267098400a8599ecd15bd217540 /setup.py
parent20d58e4a5ce099fd3884cb5fa417c6c0b24607d4 (diff)
downloadapkkit-2a46aec465207280f31dbe8031f420e8b9851ece.tar.gz
apkkit-2a46aec465207280f31dbe8031f420e8b9851ece.tar.bz2
apkkit-2a46aec465207280f31dbe8031f420e8b9851ece.tar.xz
apkkit-2a46aec465207280f31dbe8031f420e8b9851ece.zip
Add APKINDEX reading support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 119d2e8..78d1575 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-from setuptools import setup
+from setuptools import setup, find_packages
from codecs import open
from os import path
@@ -13,8 +13,8 @@ with open(path.join(here, 'README.rst'), encoding='utf-8') as f:
setup(
name='apkkit',
- version='0.5',
- description='Manage APK packages from Python',
+ version='0.6.0',
+ description='Manage APK packages and repositories from Python',
long_description=long_description,
url='http://adelielinux.org/',
author='A. Wilcox',
@@ -35,10 +35,11 @@ setup(
'Topic :: System :: Software Distribution',
],
keywords='apk packaging portage',
- packages=('apkkit',),
+ packages=find_packages(),
install_requires=[
'cryptography',
'jinja',
'pyyaml',
+ 'requests',
]
)