summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-08 02:38:58 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-11-08 02:38:58 -0600
commit386ff62ca3aba790f9831ee7c194d24f6fb781fe (patch)
tree9bb4233e965f3fe71224fd0a5983c1e631787ae4 /CMakeLists.txt
parent561db34595bd4181fde3781d3a00bab9a6d1403f (diff)
downloadhorizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.tar.gz
horizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.tar.bz2
horizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.tar.xz
horizon-386ff62ca3aba790f9831ee7c194d24f6fb781fe.zip
UI: Import some of the 2016 prototype - welcome to Qt UI development
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ec75ca..bc07267 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,7 @@ endif()
option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)
+option(BUILD_UI "Enable user interface" ON)
## Code Coverage stuff ##
@@ -82,6 +83,9 @@ add_subdirectory(owner)
IF(BUILD_TOOLS)
add_subdirectory(tools)
ENDIF(BUILD_TOOLS)
+IF(BUILD_UI)
+ add_subdirectory(ui)
+ENDIF(BUILD_UI)
IF(INSTALL)
add_subdirectory(fetch)
ENDIF(INSTALL)