summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ec75ca..bc07267 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,7 @@ endif()
option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)
+option(BUILD_UI "Enable user interface" ON)
## Code Coverage stuff ##
@@ -82,6 +83,9 @@ add_subdirectory(owner)
IF(BUILD_TOOLS)
add_subdirectory(tools)
ENDIF(BUILD_TOOLS)
+IF(BUILD_UI)
+ add_subdirectory(ui)
+ENDIF(BUILD_UI)
IF(INSTALL)
add_subdirectory(fetch)
ENDIF(INSTALL)