summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-09 09:00:02 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-02-09 09:00:02 -0600
commit5ef02583ecf0f2a954063eb80375b204f3433058 (patch)
tree6a0ec3e0b76e065deaa5387b37585493f4b247f4 /CMakeLists.txt
parent72f84dd3dd00e792083906dbf50828c9b00d0221 (diff)
downloadhorizon-5ef02583ecf0f2a954063eb80375b204f3433058.tar.gz
horizon-5ef02583ecf0f2a954063eb80375b204f3433058.tar.bz2
horizon-5ef02583ecf0f2a954063eb80375b204f3433058.tar.xz
horizon-5ef02583ecf0f2a954063eb80375b204f3433058.zip
hscript: Factor subnet -> CIDR conversion to util function
* Also ensures that the unused function in util/net (is_url_valid) doesn't break the build of network.cc (and vis versa for user.cc).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffb117f..79a5db1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,8 @@ add_definitions(-DVERSTR="${PROJECT_VERSION}")
if(MSVC)
add_compile_options(/W4 /WX)
else()
- add_compile_options(-Wall -Wextra -Wno-unused-parameter -Werror)
+ add_compile_options(-Wall -Wextra -Wno-unused-parameter -Wno-unused-function
+ -Werror)
endif()