summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-21 21:50:00 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-21 21:50:00 -0500
commit8c5782b7a29f7d72cd81fa3bc270e4423c741033 (patch)
treeb7dd4c194f006c5635ec3b930fccc53d2b388650 /CMakeLists.txt
parent07a2de27b57848789171dee2559e4bd78d0e921c (diff)
downloadhorizon-8c5782b7a29f7d72cd81fa3bc270e4423c741033.tar.gz
horizon-8c5782b7a29f7d72cd81fa3bc270e4423c741033.tar.bz2
horizon-8c5782b7a29f7d72cd81fa3bc270e4423c741033.tar.xz
horizon-8c5782b7a29f7d72cd81fa3bc270e4423c741033.zip
Use VERSTR for version instead of hardcoding
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfa8791..95e82f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,9 +4,13 @@ include(FindPkgConfig)
include(CheckIncludeFiles)
project(Horizon
- LANGUAGES CXX
+ LANGUAGES C CXX
VERSION 0.1.0)
+
+add_definitions(-DVERSTR="${PROJECT_VERSION}")
+
+
option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)