summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfa8791..95e82f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,9 +4,13 @@ include(FindPkgConfig)
include(CheckIncludeFiles)
project(Horizon
- LANGUAGES CXX
+ LANGUAGES C CXX
VERSION 0.1.0)
+
+add_definitions(-DVERSTR="${PROJECT_VERSION}")
+
+
option(BUILD_TOOLS "Enable building of tools (Validator, Simulator, etc)" ON)