summaryrefslogtreecommitdiff
path: root/image/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-03-24 07:36:25 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-03-24 07:36:25 -0500
commit1f67d2793e2abb7c833172a0a1966d76b1b9a06a (patch)
tree2a61a6a2a8bb5d5370cae8e8192ab48a12a4d4a4 /image/CMakeLists.txt
parentedad6721912ddedea21150f74cbb52a98f3910ee (diff)
downloadhorizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.tar.gz
horizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.tar.bz2
horizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.tar.xz
horizon-1f67d2793e2abb7c833172a0a1966d76b1b9a06a.zip
Add the beginnings of the Image Creation utility
Diffstat (limited to 'image/CMakeLists.txt')
-rw-r--r--image/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/image/CMakeLists.txt b/image/CMakeLists.txt
new file mode 100644
index 0000000..c978ce6
--- /dev/null
+++ b/image/CMakeLists.txt
@@ -0,0 +1,9 @@
+find_package(Boost REQUIRED COMPONENTS program_options)
+include_directories(${Boost_INCLUDE_DIR})
+
+set(IMG_SRCS
+ creator.cc
+)
+add_executable(hscript-image ${IMG_SRCS})
+target_link_libraries(hscript-image hscript ${Boost_LIBRARIES})
+install(TARGETS hscript-image DESTINATION bin)