summaryrefslogtreecommitdiff
path: root/image/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'image/CMakeLists.txt')
-rw-r--r--image/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/image/CMakeLists.txt b/image/CMakeLists.txt
new file mode 100644
index 0000000..c978ce6
--- /dev/null
+++ b/image/CMakeLists.txt
@@ -0,0 +1,9 @@
+find_package(Boost REQUIRED COMPONENTS program_options)
+include_directories(${Boost_INCLUDE_DIR})
+
+set(IMG_SRCS
+ creator.cc
+)
+add_executable(hscript-image ${IMG_SRCS})
+target_link_libraries(hscript-image hscript ${Boost_LIBRARIES})
+install(TARGETS hscript-image DESTINATION bin)