summaryrefslogtreecommitdiff
path: root/image/CMakeLists.txt
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-02 21:41:11 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-02 21:41:11 -0500
commitcd52d492ec08810fa0ba2425d5e01618a2e8741a (patch)
tree58597907a0e00d2acd0da28a2d46fb0898917da4 /image/CMakeLists.txt
parentb9fa31365c91cfcbc891b36b411d3adc296ff6df (diff)
downloadhorizon-cd52d492ec08810fa0ba2425d5e01618a2e8741a.tar.gz
horizon-cd52d492ec08810fa0ba2425d5e01618a2e8741a.tar.bz2
horizon-cd52d492ec08810fa0ba2425d5e01618a2e8741a.tar.xz
horizon-cd52d492ec08810fa0ba2425d5e01618a2e8741a.zip
image: Truly dynamic backend registration
This allows one backend to provide multiple types. For example, our TarBackend can provide optional .gz, .bz2, and .xz compression.
Diffstat (limited to 'image/CMakeLists.txt')
-rw-r--r--image/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/image/CMakeLists.txt b/image/CMakeLists.txt
index cbee674..775d38e 100644
--- a/image/CMakeLists.txt
+++ b/image/CMakeLists.txt
@@ -5,8 +5,7 @@ add_subdirectory(backends)
set(IMG_SRCS
creator.cc
- ${BACKEND_SRCS}
)
add_executable(hscript-image ${IMG_SRCS})
-target_link_libraries(hscript-image hscript ${Boost_LIBRARIES})
+target_link_libraries(hscript-image hscript hi-backends ${Boost_LIBRARIES})
install(TARGETS hscript-image DESTINATION bin)