summaryrefslogtreecommitdiff
path: root/system/libucontext/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /system/libucontext/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'system/libucontext/APKBUILD')
-rw-r--r--system/libucontext/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/system/libucontext/APKBUILD b/system/libucontext/APKBUILD
index 534e6b137..93bc2b252 100644
--- a/system/libucontext/APKBUILD
+++ b/system/libucontext/APKBUILD
@@ -2,11 +2,12 @@
pkgname=libucontext
pkgver=0.9.0
pkgrel=0
-pkgdesc="ucontext function implementations"
+pkgdesc="Implementation of software-defined threading"
url="https://code.foxkit.us/adelie/libucontext/"
arch="all"
license="ISC"
depends=""
+makedepends=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/libucontext/libucontext-$pkgver.tar.xz"
@@ -18,17 +19,14 @@ pmmx) LIBUCONTEXT_ARCH="x86" ;;
esac
build() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH"
}
check() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" check
}
package() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" DESTDIR="$pkgdir" install
}