summaryrefslogtreecommitdiff
path: root/system/libucontext/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/libucontext/APKBUILD')
-rw-r--r--system/libucontext/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/system/libucontext/APKBUILD b/system/libucontext/APKBUILD
index 534e6b137..93bc2b252 100644
--- a/system/libucontext/APKBUILD
+++ b/system/libucontext/APKBUILD
@@ -2,11 +2,12 @@
pkgname=libucontext
pkgver=0.9.0
pkgrel=0
-pkgdesc="ucontext function implementations"
+pkgdesc="Implementation of software-defined threading"
url="https://code.foxkit.us/adelie/libucontext/"
arch="all"
license="ISC"
depends=""
+makedepends=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/libucontext/libucontext-$pkgver.tar.xz"
@@ -18,17 +19,14 @@ pmmx) LIBUCONTEXT_ARCH="x86" ;;
esac
build() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH"
}
check() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" check
}
package() {
- cd "$builddir"
make ARCH="$LIBUCONTEXT_ARCH" DESTDIR="$pkgdir" install
}