summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-21 19:31:39 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-21 19:31:39 -0600
commitf12a665e59888b30042c8c3d0ce9545fc52ceea8 (patch)
tree495069ae5cb25aebd07166503cce1a3ace10dd6a /user
parent98264c3e6fa550a221317a931aeec048eebd01cd (diff)
downloadpackages-current.tar.gz
packages-current.tar.bz2
packages-current.tar.xz
packages-current.zip
user/horizon: Add upstream patch for PPC32 disksHEADcurrent
This is required to partition PPC32 disks correctly when blank. Otherwise, users will face the dreaded error: ``` /etc/horizon/installfile:8: error: partition: consistency error on /dev/sda: Partition #1 has been requested, but the disk has 1 partitions ``` This fixes that issue.
Diffstat (limited to 'user')
-rw-r--r--user/horizon/APKBUILD9
-rw-r--r--user/horizon/apm-disklabel.patch75
-rw-r--r--user/horizon/ppc32-apm.patch29
3 files changed, 35 insertions, 78 deletions
diff --git a/user/horizon/APKBUILD b/user/horizon/APKBUILD
index 0f85056f3..25cfc4d63 100644
--- a/user/horizon/APKBUILD
+++ b/user/horizon/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=horizon
pkgver=0.9.9.1
-pkgrel=0
+pkgrel=1
pkgdesc="Installation tools for Adélie Linux"
url="https://horizon.adelielinux.org/"
arch="all"
@@ -17,7 +17,9 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages="$pkgname-image $pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-qt5
$pkgname-tools $pkgname-wizard $pkgname-boot"
-source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
+ ppc32-apm.patch
+ "
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -160,4 +162,5 @@ GLOBALS
"$subpkgdir"/usr/share/xsessions/horizon.desktop
}
-sha512sums="270926f74450f3250ae168fd31fd897a0bf0e444d0fb9753ebdc571157c89e873e13ed80030d93f5b470cc1876d2f9f00527ad0df2a0d15798dc6fbd4fe0641d horizon-0.9.9.1.tar.xz"
+sha512sums="270926f74450f3250ae168fd31fd897a0bf0e444d0fb9753ebdc571157c89e873e13ed80030d93f5b470cc1876d2f9f00527ad0df2a0d15798dc6fbd4fe0641d horizon-0.9.9.1.tar.xz
+f3977cf247436301a2f8975859f888ee24ac305f7389317a4642f07d3dd6e30cea7f9076392f35187d034c6fcb7d5c4575ba007b50fc5e24577c0debd3c4a410 ppc32-apm.patch"
diff --git a/user/horizon/apm-disklabel.patch b/user/horizon/apm-disklabel.patch
deleted file mode 100644
index 368aa8b05..000000000
--- a/user/horizon/apm-disklabel.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From 5df1abdb743ac71986cabe8c76dcd9a0f75e44da Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Thu, 25 Apr 2024 23:27:30 -0500
-Subject: [PATCH] Qt UI: Fix partition count for APM disklabel
-
-The APM disklabel includes a meta partition for the partition map
-itself. This is always counted by parted as a partition, and is *not*
-considered to be a metadata partition. We therefore need to start our
-partitioning at #2 on APM, not #1.
-
-Closes: #376
----
- CHANGELOG.rst | 14 +++++++++++++-
- ui/qt5/horizonwizard.cc | 6 ++++--
- 2 files changed, 17 insertions(+), 3 deletions(-)
-
-diff --git a/CHANGELOG.rst b/CHANGELOG.rst
-index 7afcb34..b944410 100644
---- a/CHANGELOG.rst
-+++ b/CHANGELOG.rst
-@@ -5,7 +5,19 @@
- * **A. Wilcox**, documentation writer
- * **Contributors**, code
- :Copyright:
-- © 2019-2023 Adélie Linux and contributors.
-+ © 2019-2024 Adélie Linux and contributors.
-+
-+
-+
-+0.9.9 (2024-??-??)
-+==================
-+
-+Qt UI
-+-----
-+
-+* The Qt UI now counts APM partition map partitions when creating APM
-+ disklabels, fixing a long-standing bug when installing to an empty disk
-+ on PowerPC Macintosh systems.
-
-
-
-diff --git a/ui/qt5/horizonwizard.cc b/ui/qt5/horizonwizard.cc
-index 298cd15..2872eb6 100644
---- a/ui/qt5/horizonwizard.cc
-+++ b/ui/qt5/horizonwizard.cc
-@@ -400,7 +400,8 @@ QString nameForPartitionOnDisk(const std::string &dev, int part) {
- /*! Determine the correct disk label based on the target platform. */
- QStringList eraseDiskForArch(const std::string &raw_disk,
- HorizonWizard::Arch arch,
-- HorizonWizard::Subarch subarch) {
-+ HorizonWizard::Subarch subarch,
-+ int *start) {
- const auto disk = QString::fromStdString(raw_disk);
-
- switch(arch) {
-@@ -412,6 +413,7 @@ QStringList eraseDiskForArch(const std::string &raw_disk,
- case HorizonWizard::ppc64: /* Complicated */
- switch(subarch) {
- case HorizonWizard::ppc64_PowerMac:
-+ (*start)++;
- return {QString{"disklabel %1 apm"}.arg(disk)};
- case HorizonWizard::ppc64_PowerNV:
- return {QString{"disklabel %1 gpt"}.arg(disk)};
-@@ -620,7 +622,7 @@ QString HorizonWizard::toHScript() {
- int start = 1;
-
- if(erase) {
-- lines << eraseDiskForArch(chosen_disk, arch, subarch);
-+ lines << eraseDiskForArch(chosen_disk, arch, subarch, &start);
- } else {
- /* This branch will be taken when "use available space" is back. */
- Q_ASSERT(false);
---
-2.40.0
-
diff --git a/user/horizon/ppc32-apm.patch b/user/horizon/ppc32-apm.patch
new file mode 100644
index 000000000..caa5d3189
--- /dev/null
+++ b/user/horizon/ppc32-apm.patch
@@ -0,0 +1,29 @@
+From 02bab111a473e6bc45c4c95e8f17634b42e0fba9 Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Sat, 21 Dec 2024 19:18:53 -0600
+Subject: [PATCH] Qt UI: Count APM partitions correctly on PPC32
+
+The fix we did in 5df1abdb74 is not complete; we use APM on 32-bit
+PowerPC machines as well. We need to do the same workaround on PPC32
+that we do on PPC64 Power Macs.
+
+Fixes: 5df1abdb74 ("Qt UI: Fix partition count for APM disklabel")
+---
+ ui/qt5/horizonwizard.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/ui/qt5/horizonwizard.cc b/ui/qt5/horizonwizard.cc
+index 81ddcdc..9cc0690 100644
+--- a/ui/qt5/horizonwizard.cc
++++ b/ui/qt5/horizonwizard.cc
+@@ -409,6 +409,7 @@ QStringList eraseDiskForArch(const std::string &raw_disk,
+ case HorizonWizard::x86_64: /* 64-bit Intel uses GPT */
+ return {QString{"disklabel %1 gpt"}.arg(disk)};
+ case HorizonWizard::ppc: /* 32-bit PowerPC: we only support Power Mac */
++ (*start)++;
+ return {QString{"disklabel %1 apm"}.arg(disk)};
+ case HorizonWizard::ppc64: /* Complicated */
+ switch(subarch) {
+--
+2.40.0
+