summaryrefslogtreecommitdiff
path: root/user/aspell
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 05:57:00 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 17:56:35 -0500
commit97916d382fdfd1014c3f930d222a1fdc4369b101 (patch)
tree6b8df654daf7520347e152439400c3ae04ca2aa3 /user/aspell
parentbbbcddf29bdfd1860f7631014dd2b2bfcd9d7e77 (diff)
downloadpackages-97916d382fdfd1014c3f930d222a1fdc4369b101.tar.gz
packages-97916d382fdfd1014c3f930d222a1fdc4369b101.tar.bz2
packages-97916d382fdfd1014c3f930d222a1fdc4369b101.tar.xz
packages-97916d382fdfd1014c3f930d222a1fdc4369b101.zip
user/aspell: pull in, fix up, add tinfo to LIBS
Diffstat (limited to 'user/aspell')
-rw-r--r--user/aspell/APKBUILD69
1 files changed, 69 insertions, 0 deletions
diff --git a/user/aspell/APKBUILD b/user/aspell/APKBUILD
new file mode 100644
index 000000000..a2cc79f32
--- /dev/null
+++ b/user/aspell/APKBUILD
@@ -0,0 +1,69 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer:
+pkgname=aspell
+pkgver=0.60.6.1
+pkgrel=13
+pkgdesc="Libre spell checker software"
+url="http://aspell.net/"
+arch="all"
+license="LGPL-2.0+"
+subpackages="$pkgname-compat::noarch $pkgname-utils $pkgname-dev $pkgname-doc
+ $pkgname-lang $pkgname-libs"
+depends=
+depends_dev="$pkgname-utils"
+makedepends="ncurses-dev perl"
+install=
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ LIBS="-ltinfo" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-dict-dir=/usr/share/$pkgname \
+ --enable-pkgdatadir=/usr/share/$pkgname \
+ --enable-compile-in-filters
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+compat() {
+ pkgdesc="aspell compatibility scripts for ispell and unix spell"
+ depends="$pkgname"
+ install -d "$subpkgdir"/usr/bin
+ cd "$pkgdir"/usr/share/$pkgname
+ mv spell ispell "$subpkgdir"/usr/bin/
+}
+
+utils() {
+ pkgdesc="Utilities for aspell"
+ depends="$pkgname perl"
+ install -d "$subpkgdir"/usr/bin
+ cd "$pkgdir"/usr/bin
+ mv pre* aspell-import run-with-aspell word-list-compress "$subpkgdir"/usr/bin/
+}
+
+libs() {
+ default_libs
+ mv "$pkgdir"/usr/share "$subpkgdir"/usr
+ rm -fr "$pkgdir"/usr/lib
+}
+
+sha512sums="f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f aspell-0.60.6.1.tar.gz"