summaryrefslogtreecommitdiff
path: root/user/graphene/installed-tests.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-02 02:39:31 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commitf9117878f924da07105e48f152b4bf6135b29c7b (patch)
treeb2e6eaddcc1909c3830dbac7aba73382d0d1a318 /user/graphene/installed-tests.patch
parent44d711c72a91ecc565251e11a2e0de8d87d4d839 (diff)
downloadpackages-f9117878f924da07105e48f152b4bf6135b29c7b.tar.gz
packages-f9117878f924da07105e48f152b4bf6135b29c7b.tar.bz2
packages-f9117878f924da07105e48f152b4bf6135b29c7b.tar.xz
packages-f9117878f924da07105e48f152b4bf6135b29c7b.zip
user/graphene: New package
Diffstat (limited to 'user/graphene/installed-tests.patch')
-rw-r--r--user/graphene/installed-tests.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/user/graphene/installed-tests.patch b/user/graphene/installed-tests.patch
new file mode 100644
index 000000000..5a097d996
--- /dev/null
+++ b/user/graphene/installed-tests.patch
@@ -0,0 +1,28 @@
+Upstream-URL: https://github.com/ebassi/graphene/issues/247
+
+From 85289fa63b1a5e4e5a03a79b947d1db5b9ec4778 Mon Sep 17 00:00:00 2001
+From: psykose <alice@ayaya.dev>
+Date: Thu, 7 Apr 2022 19:01:49 +0000
+Subject: [PATCH] meson: don't install introspection file with
+ installed_tests=false
+
+fixes #247
+---
+ tests/meson.build | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 0a6a355..0120c29 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -67,7 +67,9 @@ src_build_path = meson.current_build_dir() / '../src'
+
+ if build_gir and host_system == 'linux' and not meson.is_cross_build()
+ foreach unit: ['introspection.py']
+- install_data(unit, install_dir: installed_test_bindir)
++ if get_option('installed_tests')
++ install_data(unit, install_dir: installed_test_bindir)
++ endif
+
+ wrapper = '@0@.test'.format(unit)
+ custom_target(wrapper,