summaryrefslogtreecommitdiff
path: root/user/khotkeys
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-06 22:47:32 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-06 22:47:32 +0000
commit26fe534666f8c8ac0e8f2c2a432e5b877f756f4c (patch)
tree6532d031eae8b1258e290ba655089bebd4b7324e /user/khotkeys
parent7fffbaf95362383c315a3f2c7989d04c178ce962 (diff)
downloadpackages-26fe534666f8c8ac0e8f2c2a432e5b877f756f4c.tar.gz
packages-26fe534666f8c8ac0e8f2c2a432e5b877f756f4c.tar.bz2
packages-26fe534666f8c8ac0e8f2c2a432e5b877f756f4c.tar.xz
packages-26fe534666f8c8ac0e8f2c2a432e5b877f756f4c.zip
user/[KDE Plasma]: Bump to 5.12.8
Diffstat (limited to 'user/khotkeys')
-rw-r--r--user/khotkeys/APKBUILD14
-rw-r--r--user/khotkeys/cmake-fixes.patch49
2 files changed, 56 insertions, 7 deletions
diff --git a/user/khotkeys/APKBUILD b/user/khotkeys/APKBUILD
index a77c93a0c..0d53161a8 100644
--- a/user/khotkeys/APKBUILD
+++ b/user/khotkeys/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox-kde@adelielinux.org>
pkgname=khotkeys
-pkgver=5.12.7
+pkgver=5.12.8
pkgrel=0
pkgdesc="Hot key mapping for KDE Plasma 5"
url="https://www.KDE.org/"
@@ -13,10 +13,11 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev kcmutils-dev
kxmlgui-dev libice-dev libx11-dev plasma-framework-dev
plasma-workspace-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/khotkeys-$pkgver.tar.xz
+ cmake-fixes.patch
+ "
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -32,13 +33,12 @@ build() {
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="5cdfb182fc6c5edabc7bd979c86c423243ab390e25981359c68cfb1a258503fdf26b723399f4e3a688212c3a92703aaeb359b7c71ada216657282952dd4092b4 khotkeys-5.12.7.tar.xz"
+sha512sums="df60c9d9be901cfeb6cc41e006015b98f373493362c10cf54bc479eb60a3d7ef33aca557497cdae32e351fd413a615620bbc04d53b42bd7ff7de458c36f8c170 khotkeys-5.12.8.tar.xz
+1c2558d8b142bc1de236e35b8f55a825f55d4c38c2b5cb2fbf02dcae1128325f45b15246f9c9d874d1afd2a4483df8501877121c6052b6d067892c5fbeca1dc5 cmake-fixes.patch"
diff --git a/user/khotkeys/cmake-fixes.patch b/user/khotkeys/cmake-fixes.patch
new file mode 100644
index 000000000..6f6bfcc5d
--- /dev/null
+++ b/user/khotkeys/cmake-fixes.patch
@@ -0,0 +1,49 @@
+From ae5743738245437332b1bb670b9a3f8c429211e2 Mon Sep 17 00:00:00 2001
+From: David Faure <faure@kde.org>
+Date: Sun, 10 Feb 2019 20:26:25 +0100
+Subject: Harmonize usage of HAVE_X11, using #if and #cmakedefine01.
+
+---
+ CMakeLists.txt | 1 +
+ config-X11.h.cmake | 2 +-
+ libkhotkeysprivate/conditions/existing_window_condition.h | 1 -
+ 3 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2a96e3b..0955f4e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -37,6 +37,7 @@ find_package(LibKWorkspace CONFIG REQUIRED)
+ if(X11_FOUND)
+ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS X11Extras )
+ set(HAVE_XTEST ${X11_XTest_FOUND})
++ set(HAVE_X11 1)
+ endif()
+
+ configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h)
+diff --git a/config-X11.h.cmake b/config-X11.h.cmake
+index 60286dd..ae8978a 100644
+--- a/config-X11.h.cmake
++++ b/config-X11.h.cmake
+@@ -41,4 +41,4 @@
+ #cmakedefine HAS_RANDR_1_3 1
+
+ /* Define if you have X11 at all */
+-#define HAVE_X11 ${X11_FOUND}
+\ No newline at end of file
++#cmakedefine01 HAVE_X11
+diff --git a/libkhotkeysprivate/conditions/existing_window_condition.h b/libkhotkeysprivate/conditions/existing_window_condition.h
+index 92815eb..b6a4278 100644
+--- a/libkhotkeysprivate/conditions/existing_window_condition.h
++++ b/libkhotkeysprivate/conditions/existing_window_condition.h
+@@ -26,7 +26,6 @@
+
+ #include <KConfig> // Needed because of some Qt Status redefinitions
+ #include <KConfigGroup> // Needed because of some Qt Status redefinitions
+-#include <config-kwindowsystem.h> // Needed for HAVE_X11
+ #include <config-X11.h>
+ #include <kdemacros.h>
+
+--
+cgit v1.1
+