summaryrefslogtreecommitdiff
path: root/user/kpimtextedit
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-19 07:33:49 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-19 07:33:49 +0000
commite4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e (patch)
tree765c43e23668dd79b2dab94029fb96813c7f824e /user/kpimtextedit
parent6162950549630e75dd1f2d3037cabd23559b2822 (diff)
downloadpackages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.gz
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.bz2
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.xz
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.zip
user/*: KDE Applications 19.04.0
Diffstat (limited to 'user/kpimtextedit')
-rw-r--r--user/kpimtextedit/APKBUILD9
-rw-r--r--user/kpimtextedit/qt5.9.patch49
2 files changed, 55 insertions, 3 deletions
diff --git a/user/kpimtextedit/APKBUILD b/user/kpimtextedit/APKBUILD
index ed683d6b7..ca7ae9c47 100644
--- a/user/kpimtextedit/APKBUILD
+++ b/user/kpimtextedit/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=kpimtextedit
-pkgver=18.12.3
+pkgver=19.04.0
pkgrel=0
pkgdesc="Text editor for Personal Information Managers (PIMs)"
url="https://pim.kde.org/"
@@ -16,7 +16,9 @@ makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev ki18n-dev
kdesignerplugin-dev kemoticons-dev kiconthemes-dev kio-dev kxmlgui-dev
qt5-qtspeech-dev"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/kpimtextedit-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/kpimtextedit-$pkgver.tar.xz
+ qt5.9.patch
+ "
build() {
cd "$builddir"
@@ -44,4 +46,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c3f4d3143a56cad623a5fb514c2234e4f00c07f395e72648ed3429a88631e3c752ea55d321fe55584f1846d3f97fabf3796ce3883cba06238f00e735028853bb kpimtextedit-18.12.3.tar.xz"
+sha512sums="dabddde9d7ee98927c10234ca9e6540c55417eabf930c66afaa8c88d5ab289bbadb20e2c0cf6334aa199a780bc6e54d1afa0ac981606c0b5316f992c06b67cb2 kpimtextedit-19.04.0.tar.xz
+13f90299735e145142f969ffb6462b71c1cd85d5503c3902af924388042396526ff8b943229462e0ff7e5030393e5312dd67b8dfc66efec81f4f05ac15f86091 qt5.9.patch"
diff --git a/user/kpimtextedit/qt5.9.patch b/user/kpimtextedit/qt5.9.patch
new file mode 100644
index 000000000..50c29e0e0
--- /dev/null
+++ b/user/kpimtextedit/qt5.9.patch
@@ -0,0 +1,49 @@
+From 6961b54d1c814f2e7aafd7db8256f82688f014a3 Mon Sep 17 00:00:00 2001
+Date: Mon, 17 Dec 2018 07:23:52 +0100
+Subject: Revert "Remove QT_CHECK"
+
+---
+ .../plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp b/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
+index 8ce0fe9..c07699c 100644
+--- a/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
++++ b/src/texteditor/plaintexteditor/plaintextsyntaxspellcheckinghighlighter.cpp
+@@ -144,9 +144,13 @@ void PlainTextSyntaxSpellCheckingHighlighter::highlightBlock(const QString &text
+
+ const auto nextBlock = currentBlock().next();
+ if (nextBlock.isValid()) {
++#if QT_VERSION >= QT_VERSION_CHECK(5, 10, 0)
+ QMetaObject::invokeMethod(this, [this, nextBlock] {
+ rehighlightBlock(nextBlock);
+ }, Qt::QueuedConnection);
++#else
++ QMetaObject::invokeMethod(this, "rehighlightBlock", Qt::QueuedConnection, Q_ARG(QTextBlock, nextBlock));
++#endif
+ }
+ }
+
+--
+cgit v1.1
+
+--- kpimtextedit-19.04.0/CMakeLists.txt.old 2019-04-12 00:14:22.000000000 +0000
++++ kpimtextedit-19.04.0/CMakeLists.txt 2019-04-19 06:21:56.055556133 +0000
+@@ -4,7 +4,7 @@
+ project(KPimTextEdit VERSION ${PIM_VERSION})
+
+ # ECM setup
+-set(KF5_MIN_VERSION "5.56.0")
++set(KF5_MIN_VERSION "5.54.0")
+
+ find_package(ECM ${KF5_MIN_VERSION} CONFIG REQUIRED)
+ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH})
+@@ -36,7 +36,7 @@
+ SOVERSION 5
+ )
+
+-set(QT_REQUIRED_VERSION "5.10.0")
++set(QT_REQUIRED_VERSION "5.9.0")
+ find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED COMPONENTS Widgets)
+ find_package(Grantlee5 "5.1" CONFIG REQUIRED)
+ set_package_properties(Grantlee5 PROPERTIES