summaryrefslogtreecommitdiff
path: root/user/labplot
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-18 23:17:46 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-18 23:17:46 +0000
commit001e445e6d5f8c4f7fa210654c94c38f72e7265a (patch)
treee2162c7d8979650f460f5ffbcf126b99d50781dc /user/labplot
parent771cf82b73d2d6e0f79dd6be87267205f65cccf1 (diff)
downloadpackages-001e445e6d5f8c4f7fa210654c94c38f72e7265a.tar.gz
packages-001e445e6d5f8c4f7fa210654c94c38f72e7265a.tar.bz2
packages-001e445e6d5f8c4f7fa210654c94c38f72e7265a.tar.xz
packages-001e445e6d5f8c4f7fa210654c94c38f72e7265a.zip
user/labplot: rebuild for cantor bump, disable X11 tests
Diffstat (limited to 'user/labplot')
-rw-r--r--user/labplot/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/user/labplot/APKBUILD b/user/labplot/APKBUILD
index d6ed5bf7e..0e2d99394 100644
--- a/user/labplot/APKBUILD
+++ b/user/labplot/APKBUILD
@@ -2,10 +2,11 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=labplot
pkgver=2.6
-pkgrel=0
+pkgrel=1
pkgdesc="Interactive tool for graphing and analysis of scientific data"
url="https://www.kde.org/applications/education/labplot2"
arch="all"
+options="!check" # all tests require X11
license="GPL-2.0-only"
depends="shared-mime-info"
makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
@@ -18,7 +19,6 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/labplot/$pkgver.0/labplot-$pkgver.0.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -34,13 +34,11 @@ build() {
}
check() {
- cd "$builddir"
# gives incorrect results
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E fittest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}