summaryrefslogtreecommitdiff
path: root/user/labplot
diff options
context:
space:
mode:
Diffstat (limited to 'user/labplot')
-rw-r--r--user/labplot/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/user/labplot/APKBUILD b/user/labplot/APKBUILD
index d6ed5bf7e..0e2d99394 100644
--- a/user/labplot/APKBUILD
+++ b/user/labplot/APKBUILD
@@ -2,10 +2,11 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=labplot
pkgver=2.6
-pkgrel=0
+pkgrel=1
pkgdesc="Interactive tool for graphing and analysis of scientific data"
url="https://www.kde.org/applications/education/labplot2"
arch="all"
+options="!check" # all tests require X11
license="GPL-2.0-only"
depends="shared-mime-info"
makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
@@ -18,7 +19,6 @@ subpackages="$pkgname-doc $pkgname-lang"
source="https://download.kde.org/stable/labplot/$pkgver.0/labplot-$pkgver.0.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -34,13 +34,11 @@ build() {
}
check() {
- cd "$builddir"
# gives incorrect results
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E fittest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}