summaryrefslogtreecommitdiff
path: root/user/libfreehand
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 04:54:42 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 04:54:42 +0000
commit005eabd6ba6d45e5069458026dec75abc5261bb4 (patch)
treeb4e46b7efece9175d1a6351dfd30c64b958af8c1 /user/libfreehand
parent561d61fd90abdf4f460e722a8251584e584c058a (diff)
downloadpackages-005eabd6ba6d45e5069458026dec75abc5261bb4.tar.gz
packages-005eabd6ba6d45e5069458026dec75abc5261bb4.tar.bz2
packages-005eabd6ba6d45e5069458026dec75abc5261bb4.tar.xz
packages-005eabd6ba6d45e5069458026dec75abc5261bb4.zip
user/*: Modernise / fix syntax / deps / code
Diffstat (limited to 'user/libfreehand')
-rw-r--r--user/libfreehand/APKBUILD14
-rw-r--r--user/libfreehand/icu.patch11
2 files changed, 18 insertions, 7 deletions
diff --git a/user/libfreehand/APKBUILD b/user/libfreehand/APKBUILD
index b8371ac74..fc9354ab4 100644
--- a/user/libfreehand/APKBUILD
+++ b/user/libfreehand/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libfreehand
pkgver=0.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="Import filter and tools for Adobe FreeHand documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
arch="all"
license="MPL-2.0 AND Public-Domain"
depends=""
depends_dev="libxml2-dev lcms2-dev icu-dev"
-makedepends="$depends_dev gperf perl doxygen librevenge-dev zlib-dev"
checkdepends="cppunit-dev"
+makedepends="$depends_dev gperf perl doxygen librevenge-dev zlib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz
+ icu.patch
+ "
prepare() {
default_prepare
@@ -20,7 +22,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -48,4 +47,5 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963 libfreehand-0.1.2.tar.xz"
+sha512sums="4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963 libfreehand-0.1.2.tar.xz
+5c72ee92e1b617dd0ece1a17e84c4b063454811aae484a08d2e15a29c6561068d0127222656647bd0ac05afde8c5c2154d382b4289b86e1956bf173ed4694a76 icu.patch"
diff --git a/user/libfreehand/icu.patch b/user/libfreehand/icu.patch
new file mode 100644
index 000000000..22d118cca
--- /dev/null
+++ b/user/libfreehand/icu.patch
@@ -0,0 +1,11 @@
+--- libfreehand-0.1.2/src/lib/libfreehand_utils.cpp.old 2017-09-16 10:28:50.000000000 +0000
++++ libfreehand-0.1.2/src/lib/libfreehand_utils.cpp 2020-01-12 04:40:38.492246789 +0000
+@@ -162,7 +162,7 @@
+ while (j < length)
+ {
+ UChar32 c;
+- U16_NEXT(s, j, length, c)
++ U16_NEXT(s, j, length, c);
+ unsigned char outbuf[U8_MAX_LENGTH+1];
+ int i = 0;
+ U8_APPEND_UNSAFE(&outbuf[0], i, c);