summaryrefslogtreecommitdiff
path: root/user/libutempter
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-29 14:56:44 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-29 14:56:44 +0000
commit874e95bb992191beef16484b20a7ddca5e72dd20 (patch)
treede84c848fcd447c2c61962eb310eda03881126e2 /user/libutempter
parentb66a3d7f8ada41322c86651edfbae5d763391368 (diff)
downloadpackages-874e95bb992191beef16484b20a7ddca5e72dd20.tar.gz
packages-874e95bb992191beef16484b20a7ddca5e72dd20.tar.bz2
packages-874e95bb992191beef16484b20a7ddca5e72dd20.tar.xz
packages-874e95bb992191beef16484b20a7ddca5e72dd20.zip
user/libutempter: actually make the library work
Diffstat (limited to 'user/libutempter')
-rw-r--r--user/libutempter/APKBUILD12
-rw-r--r--user/libutempter/fix-linking.patch11
2 files changed, 18 insertions, 5 deletions
diff --git a/user/libutempter/APKBUILD b/user/libutempter/APKBUILD
index 5d4a3841c..058530412 100644
--- a/user/libutempter/APKBUILD
+++ b/user/libutempter/APKBUILD
@@ -1,30 +1,32 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libutempter
pkgver=1.1.6
-pkgrel=0
+pkgrel=1
pkgdesc="Library to record virtual terminal sessions in login files"
url="No URL"
arch="all"
-options="!check" # No test suite.
+options="!check suid" # No test suite.
license="LGPL-2.1+"
depends=""
makedepends="utmps-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="ftp://ftp.altlinux.org/pub/people/ldv/utempter/$pkgname-$pkgver.tar.bz2
+ fix-linking.patch
port-to-utmpx.patch
"
build() {
cd "$builddir"
- make
+ make LDLIBS="-lutmps -lskarnet"
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
- # utmps allows us to log without root!
- chmod 0755 "$pkgdir"/usr/lib/utempter/utempter
+ # we need to be setuid, not setgid
+ chmod 4711 "$pkgdir"/usr/lib/utempter/utempter
}
sha512sums="6ada410b981d157ae20b578de8ce20997ec0446ec6de6859549b080aa65976fc9900d211600dab09dc3d0d109daabad0994a648b093b8781b442ff26ca17fede libutempter-1.1.6.tar.bz2
+c5abc344544ac962dfc7ba6a5a7c807120e03db5b2cc7111613934322ee7041e5e97db10643cab6bbf734b3f5687f8db3a7e375b04f9b952b7c7e33b4f0431e7 fix-linking.patch
b2d0bc9075bda0dc3404458547ee2d190855d6d8b2c209ae70b763ea11baa0569bd3b167589ad09f77c82075430ca60ffe758a925b9fd4124b5945b93c19a10d port-to-utmpx.patch"
diff --git a/user/libutempter/fix-linking.patch b/user/libutempter/fix-linking.patch
new file mode 100644
index 000000000..91719507a
--- /dev/null
+++ b/user/libutempter/fix-linking.patch
@@ -0,0 +1,11 @@
+--- libutempter-1.1.6/Makefile.old 2010-11-04 17:14:53.000000000 +0000
++++ libutempter-1.1.6/Makefile 2018-08-29 14:47:24.740000000 +0000
+@@ -52,7 +52,7 @@
+ $(COMPILE.c) -fPIC $< $(OUTPUT_OPTION)
+
+ $(PROJECT): utempter.c
+- $(LINK.c) -Wl,-z,now,-stats $(LDLIBS) $< $(OUTPUT_OPTION)
++ $(LINK.c) -Wl,-z,now,-stats $< $(OUTPUT_OPTION) $(LDLIBS)
+
+ $(SHAREDLIB): iface.os $(MAP)
+ $(LINK.o) -shared \