summaryrefslogtreecommitdiff
path: root/user/mosquitto
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-22 19:16:01 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:58 -0500
commit436798a6bc2e2a5d64ff6fdc4451fb59cc1f0de7 (patch)
treead35357c21d5532099ac67ce43cd4e54aeefcfd3 /user/mosquitto
parentb722efca6bc9b961a0dbfae8aa56b47a912a2819 (diff)
downloadpackages-436798a6bc2e2a5d64ff6fdc4451fb59cc1f0de7.tar.gz
packages-436798a6bc2e2a5d64ff6fdc4451fb59cc1f0de7.tar.bz2
packages-436798a6bc2e2a5d64ff6fdc4451fb59cc1f0de7.tar.xz
packages-436798a6bc2e2a5d64ff6fdc4451fb59cc1f0de7.zip
user/mosquitto: bump { 1.6.10 --> 2.0.14 }. enable most tests. see #687.
Diffstat (limited to 'user/mosquitto')
-rw-r--r--user/mosquitto/APKBUILD24
-rw-r--r--user/mosquitto/disable-flaky-test.patch25
2 files changed, 15 insertions, 34 deletions
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index 71e1fb99c..317988a70 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -2,21 +2,20 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mosquitto
-pkgver=1.6.10
+pkgver=2.0.14
pkgrel=0
pkgdesc="An Open Source MQTT Broker"
url="https://mosquitto.org/"
arch="all"
license="EPL-1.0 AND EDL-1.0 AND MIT AND BSD-3-Clause"
depends=""
-checkdepends="python3"
-makedepends="c-ares-dev openssl-dev util-linux-dev"
+checkdepends="python3 ca-certificates cunit-dev"
+makedepends="c-ares-dev openssl-dev util-linux-dev cjson-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-openrc
$pkgname-clients"
install="$pkgname.pre-install"
source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
mosquitto.initd
- disable-flaky-test.patch
openrc-conf.patch
"
@@ -46,9 +45,17 @@ build() {
}
check() {
- # Unit tests require cunit, so skip them.
- make -j1 -C test/broker test
- make -j1 -C test/lib test
+ # Explicitly disable tests, instead of enabling only good ones.
+ sed -i test/broker/test.py \
+ -e '/08-ssl-connect-cert-auth-without.py/d' `#687` \
+ ;
+ sed -i test/lib/test.py \
+ -e '/02-subscribe-qos1.py/d' \
+ ;
+ sed -i test/client/Makefile \
+ -e '/test.sh/d' \
+ ;
+ make ptest
}
package() {
@@ -73,7 +80,6 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="2050a7a7af864057a177728f1cab9f6db70d6d1ea609d90c637723c2c9cfc9716429739302abd6742bde932716fae340854fff35956693dfee4ef31ce7b04a25 mosquitto-1.6.10.tar.gz
+sha512sums="a9e4f41b9af679b30318570e86a465546024651373df10e3b132f4593b89d22d0dbac01bb7371a57132ba030a2e73971c612acb5c9ac12f5ccd06aa38d9444c2 mosquitto-2.0.14.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
-daaae48d49e49a9911f152dfc80f67f2371ad62647d3324b360eb83f816c0898469c135209ddb69e80a29b313bbe3b6ee11463955c97a44584921c13832a07be disable-flaky-test.patch
b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch"
diff --git a/user/mosquitto/disable-flaky-test.patch b/user/mosquitto/disable-flaky-test.patch
deleted file mode 100644
index 1dade3cd4..000000000
--- a/user/mosquitto/disable-flaky-test.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- mosquitto-1.6.4/test/broker/Makefile 2019-08-01 19:50:01.000000000 +0000
-+++ mosquitto-1.6.4/test/broker/Makefile 2019-08-28 00:03:54.430562623 +0000
-@@ -193,7 +193,7 @@ endif
- ./10-listener-mount-point.py
-
- 11 :
-- ./11-message-expiry.py
-+ #./11-message-expiry.py
- ./11-persistent-subscription.py
- ./11-persistent-subscription-v5.py
- ./11-persistent-subscription-no-local.py
-
-Upstream issue: https://github.com/eclipse/mosquitto/issues/1659
-
---- mosquitto-1.6.10/test/lib/Makefile 2020-05-25 22:49:59.000000000 +0000
-+++ mosquitto-1.6.10/test/lib/Makefile 2020-06-20 01:41:00.350012338 +0000
-@@ -33,7 +33,7 @@ c : test-compile
- ./02-subscribe-qos0.py $@/02-subscribe-qos0.test
- ./02-subscribe-qos1.py $@/02-subscribe-qos1.test
- ./02-subscribe-qos1.py $@/02-subscribe-qos1-async1.test
-- ./02-subscribe-qos1.py $@/02-subscribe-qos1-async2.test
-+ #./02-subscribe-qos1.py $@/02-subscribe-qos1-async2.test
- ./02-subscribe-qos2.py $@/02-subscribe-qos2.test
- ./02-unsubscribe-multiple-v5.py $@/02-unsubscribe-multiple-v5.test
- ./02-unsubscribe-v5.py $@/02-unsubscribe-v5.test