summaryrefslogtreecommitdiff
path: root/user/py3-iniconfig/APKBUILD
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-11 21:36:39 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc (patch)
tree931e6d5cfddd191e983aa19b89af1de597f68646 /user/py3-iniconfig/APKBUILD
parent3e3aa629a86fab53f434e0a5a87926b0856ccd7b (diff)
downloadpackages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.gz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.bz2
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.xz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.zip
user/py3-*: bunch of new py3 packages and updates. fixes #458, #459.
Diffstat (limited to 'user/py3-iniconfig/APKBUILD')
-rw-r--r--user/py3-iniconfig/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/user/py3-iniconfig/APKBUILD b/user/py3-iniconfig/APKBUILD
new file mode 100644
index 000000000..773284ec6
--- /dev/null
+++ b/user/py3-iniconfig/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=py3-iniconfig
+_pyname=iniconfig
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="Simple INI configuration parsing for Python"
+url="https://github.com/RonnyPfannschmidt/iniconfig"
+arch="noarch"
+options="!check" # Requires PyTest, which requires iniconfig.
+license="MIT"
+depends="python3"
+makedepends="py3-py"
+source="https://files.pythonhosted.org/packages/source/i/$_pyname/$_pyname-$pkgver.tar.gz
+ version.patch
+ "
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c9341db7e3ec2204b6a674fca7824cbeb492e3576d5ac3f084b234c82842b28f2f6acbfdb812e183f4334a95b990551f942a4caf548f5ce7ef14885f931535ee iniconfig-1.1.1.tar.gz
+bcc29e3ab250a8b9aaa496b2bb8f52a03f56faf8a73268c388959ee1090cd5fc86f11b5c6c339f1b9b9c9697984f3a956425b9d392507b69ec0e4aa543e97a92 version.patch"