summaryrefslogtreecommitdiff
path: root/user/py3-sortedcontainers
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-01-11 21:36:39 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc (patch)
tree931e6d5cfddd191e983aa19b89af1de597f68646 /user/py3-sortedcontainers
parent3e3aa629a86fab53f434e0a5a87926b0856ccd7b (diff)
downloadpackages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.gz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.bz2
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.tar.xz
packages-7e6c4c26fa4b95fe165a24c022a01c9fc05e73bc.zip
user/py3-*: bunch of new py3 packages and updates. fixes #458, #459.
Diffstat (limited to 'user/py3-sortedcontainers')
-rw-r--r--user/py3-sortedcontainers/APKBUILD27
1 files changed, 11 insertions, 16 deletions
diff --git a/user/py3-sortedcontainers/APKBUILD b/user/py3-sortedcontainers/APKBUILD
index 86b3330b7..9220bf117 100644
--- a/user/py3-sortedcontainers/APKBUILD
+++ b/user/py3-sortedcontainers/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=py3-sortedcontainers
-_pkgname=sortedcontainers
-_p="${_pkgname#?}"
-_p="${_pkgname%"$_p"}"
-pkgver=2.2.2
+_pkgname=python-sortedcontainers
+pkgver=2.4.0
pkgrel=0
-pkgdesc="Sorted container objects for Python 3"
-url="https://pypi.python.org/pypi/sortedcontainers"
+pkgdesc="Python library for sorting collections and containers"
+url="http://www.grantjenks.com/docs/sortedcontainers"
arch="noarch"
-options="!check" # See checkdepends comment below.
license="Apache-2.0"
depends="python3"
-# requires unpackaged filelock, toml; requires importlib_metadata<1
-#checkdepends="py3-importlib_metadata py3-packaging py3-tox"
-makedepends="python3-dev"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+checkdepends="py3-pytest"
+makedepends="py3-iniconfig"
+source="https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -23,12 +20,10 @@ build() {
}
check() {
- python3 setup.py test
+ PYTHONPATH="$PWD"/build/lib python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
}
-
-sha512sums="4a7da8d76111b56bda432b211c11ef48ac8af25ddf7fd961cf72628c18f878a6c2a22e272e108f3e5ad88a333b8f646b54c8dd11c9c642349c9da001140abd16 py3-sortedcontainers-2.2.2.tar.gz"
+sha512sums="f80185c6f95a85cc78f88f6f6cf389eb48be22cf94d5fcd84f3592873f17de37ec7f44c1627b7f02956ac4b4f74ca4febefc47d3c6232f70ee05dbb2449ad770 python-sortedcontainers-2.4.0.tar.gz"