summaryrefslogtreecommitdiff
path: root/user/py3-twisted
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-12-04 00:40:14 +0000
committerZach van Rijn <me@zv.io>2022-12-03 19:07:34 -0600
commit57ba41a5c0b9244b3e87536235a3ce4e28c44c64 (patch)
treebeb3fca4477bc0ebd0f34d9b153e5fbc1bb0648c /user/py3-twisted
parentc81cec7ae4c29127d951fbf6219ddd2c1ce7086d (diff)
downloadpackages-57ba41a5c0b9244b3e87536235a3ce4e28c44c64.tar.gz
packages-57ba41a5c0b9244b3e87536235a3ce4e28c44c64.tar.bz2
packages-57ba41a5c0b9244b3e87536235a3ce4e28c44c64.tar.xz
packages-57ba41a5c0b9244b3e87536235a3ce4e28c44c64.zip
user/py3-twisted: Regenerate raiser.c for Py3.11
Fixes: #895
Diffstat (limited to 'user/py3-twisted')
-rw-r--r--user/py3-twisted/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/user/py3-twisted/APKBUILD b/user/py3-twisted/APKBUILD
index 408081052..8bc9e72dd 100644
--- a/user/py3-twisted/APKBUILD
+++ b/user/py3-twisted/APKBUILD
@@ -13,7 +13,7 @@ arch="all"
# also need to be packaged and added to depends=
options="net"
license="MIT"
-depends="python3 py3-attrs py3-incremental py3-zope-interface"
+depends="python3 py3-attrs py3-cython py3-incremental py3-zope-interface"
makedepends="python3-dev"
subpackages=""
source="https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.bz2
@@ -30,6 +30,7 @@ builddir="$srcdir/Twisted-$pkgver"
# - CVE-2020-10109
build() {
+ (cd "$builddir"/src/twisted/test && cython raiser.pyx)
python3 setup.py build
}