summaryrefslogtreecommitdiff
path: root/user/qt5-qtdeclarative
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-09 19:48:38 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-09 19:48:38 -0500
commitf1fc0e6ecae7dc68c91361f3836b8e03b8cd169c (patch)
tree034e317ec6085e521ba46bf7a07d15d0c8fb9943 /user/qt5-qtdeclarative
parent00add29283170ea81e0e6631a33a38975fd898ea (diff)
downloadpackages-f1fc0e6ecae7dc68c91361f3836b8e03b8cd169c.tar.gz
packages-f1fc0e6ecae7dc68c91361f3836b8e03b8cd169c.tar.bz2
packages-f1fc0e6ecae7dc68c91361f3836b8e03b8cd169c.tar.xz
packages-f1fc0e6ecae7dc68c91361f3836b8e03b8cd169c.zip
user/qt5-qtdeclarative: new package
Diffstat (limited to 'user/qt5-qtdeclarative')
-rw-r--r--user/qt5-qtdeclarative/APKBUILD39
-rw-r--r--user/qt5-qtdeclarative/add-execinfo.patch16
-rw-r--r--user/qt5-qtdeclarative/broken-bgra-be.patch11
3 files changed, 66 insertions, 0 deletions
diff --git a/user/qt5-qtdeclarative/APKBUILD b/user/qt5-qtdeclarative/APKBUILD
new file mode 100644
index 000000000..7f4e9c166
--- /dev/null
+++ b/user/qt5-qtdeclarative/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=qt5-qtdeclarative
+_pkgname=${pkgname/qt5-/}-opensource-src
+pkgver=5.9.6
+pkgrel=1
+pkgdesc="Qt 5 - Qt Declarative and Qt Quick 2"
+url="https://qt.io/"
+arch="all"
+license="LGPL-2.0 with exceptions OR GPL-3.0 with exceptions"
+makedepends="qt5-qtbase-dev libexecinfo-dev"
+subpackages="$pkgname-dev"
+source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
+ add-execinfo.patch"
+
+_qt5_prefix=/usr/lib/qt5
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ qmake && make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install INSTALL_ROOT="$pkgdir"
+
+ mkdir -p "$pkgdir"/usr/bin/
+ for i in "$pkgdir"/$_qt5_prefix/bin/*; do
+ ln -s ../lib/qt5/bin/${i##*/} "$pkgdir"/usr/bin/${i##*/}
+ done
+}
+
+sha512sums="1fc7a542c60e8c13ba9b791d7b83a916fc1ffb1d3ab505405055a13d597a2c406f29bbd9309603af5bf56492874efeee33ab0128af1fa44866d66d689147ac39 qtdeclarative-opensource-src-5.9.6.tar.xz
+065ab2440fd0a81e76fe8873b0991929fad3d4189c8938e0205e94478a6cdce81ef710e3bad19cd5ca0b5ea0f8b3cd1b366969ddede51070496d1d02ace59220 add-execinfo.patch"
diff --git a/user/qt5-qtdeclarative/add-execinfo.patch b/user/qt5-qtdeclarative/add-execinfo.patch
new file mode 100644
index 000000000..92fbe43ac
--- /dev/null
+++ b/user/qt5-qtdeclarative/add-execinfo.patch
@@ -0,0 +1,16 @@
+backtrace is required.
+
+This patch is not upstreamable because there is no way to determine if a Linux
+build is musl or glibc from qmake.
+
+--- qtdeclarative-opensource-src-5.9.6/src/quick/quick.pro.old 2018-05-30 11:29:13.000000000 +0000
++++ qtdeclarative-opensource-src-5.9.6/src/quick/quick.pro 2018-07-10 00:42:03.150000000 +0000
+@@ -16,6 +16,8 @@
+ LIBS_PRIVATE += -lgcov
+ }
+
++LIBS_PRIVATE += -lexecinfo
++
+ QMAKE_DOCS = $$PWD/doc/qtquick.qdocconf
+
+ ANDROID_LIB_DEPENDENCIES = \
diff --git a/user/qt5-qtdeclarative/broken-bgra-be.patch b/user/qt5-qtdeclarative/broken-bgra-be.patch
new file mode 100644
index 000000000..68cd17d77
--- /dev/null
+++ b/user/qt5-qtdeclarative/broken-bgra-be.patch
@@ -0,0 +1,11 @@
+--- qtdeclarative-opensource-src-5.9.3/src/quick/scenegraph/util/qsgatlastexture.cpp.old 2017-11-17 12:15:09.000000000 -0600
++++ qtdeclarative-opensource-src-5.9.3/src/quick/scenegraph/util/qsgatlastexture.cpp 2018-07-02 21:00:34.620000000 -0500
+@@ -147,6 +147,8 @@
+ && (deviceName->compare(QLatin1String("samsung SM-T211"), Qt::CaseInsensitive) == 0
+ || deviceName->compare(QLatin1String("samsung SM-T210"), Qt::CaseInsensitive) == 0
+ || deviceName->compare(QLatin1String("samsung SM-T215"), Qt::CaseInsensitive) == 0);
++#elif Q_BYTE_ORDER == Q_BIG_ENDIAN
++ static bool wrongfullyReportsBgra8888Support = true;
+ #else
+ static bool wrongfullyReportsBgra8888Support = false;
+ // The Raspberry Pi (both 1 and 2) GPU refuses framebuffers with BGRA color attachments.