summaryrefslogtreecommitdiff
path: root/user/speex
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 23:17:47 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 23:17:47 -0500
commit3e48a440a5fe6f14babfe5c77d25302433c68b37 (patch)
treedd492c80e40a29229afdf11b278aab1a37560358 /user/speex
parentc49fe977e8c43da67c7c2332bf5993a5e0a0d52b (diff)
downloadpackages-3e48a440a5fe6f14babfe5c77d25302433c68b37.tar.gz
packages-3e48a440a5fe6f14babfe5c77d25302433c68b37.tar.bz2
packages-3e48a440a5fe6f14babfe5c77d25302433c68b37.tar.xz
packages-3e48a440a5fe6f14babfe5c77d25302433c68b37.zip
user/speex: This is a commit of Speex, an audio compression codec specifically tuned for the reproduction of human speech
Diffstat (limited to 'user/speex')
-rw-r--r--user/speex/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/user/speex/APKBUILD b/user/speex/APKBUILD
new file mode 100644
index 000000000..c39ae6691
--- /dev/null
+++ b/user/speex/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer:
+pkgname=speex
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Audio compression format designed for speech"
+url="https://www.speex.org/"
+arch="all"
+options="!check" # Test suite is for Win32 only.
+license="BSD-3-Clause"
+depends=""
+makedepends="libogg-dev speexdsp-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="https://downloads.us.xiph.org/releases/speex/speex-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static \
+ --enable-binaries
+ make
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+tools() {
+ pkgdesc="$pkgdesc - command line tools"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+sha512sums="7fe10838c7d1bafcbe42295b82b79262420dba793b8a4388e2f73a3007850b5572face1b5308d9f4e8d7dfc9cb1c016cbad88cd65b2892667986107ed946836b speex-1.2.0.tar.gz"