summaryrefslogtreecommitdiff
path: root/user/tipidee/tipidee.pre-install
diff options
context:
space:
mode:
authorLaurent Bercot <ska-adelie@skarnet.org>2024-04-16 17:05:19 +0000
committerZach van Rijn <me@zv.io>2024-04-25 02:48:27 +0000
commita13ce58908653b32ec910c381db3aa8d54aced30 (patch)
treea57d25385ec57031bf0bc98b69b9a33210d42297 /user/tipidee/tipidee.pre-install
parent147011dc0b52b7caaa45671585612c626687ffd8 (diff)
downloadpackages-a13ce58908653b32ec910c381db3aa8d54aced30.tar.gz
packages-a13ce58908653b32ec910c381db3aa8d54aced30.tar.bz2
packages-a13ce58908653b32ec910c381db3aa8d54aced30.tar.xz
packages-a13ce58908653b32ec910c381db3aa8d54aced30.zip
user/tipidee: improve APKBUILD, fix packaging nits
Diffstat (limited to 'user/tipidee/tipidee.pre-install')
-rw-r--r--user/tipidee/tipidee.pre-install6
1 files changed, 3 insertions, 3 deletions
diff --git a/user/tipidee/tipidee.pre-install b/user/tipidee/tipidee.pre-install
index 0ef043441..e92fd1d0a 100644
--- a/user/tipidee/tipidee.pre-install
+++ b/user/tipidee/tipidee.pre-install
@@ -1,7 +1,7 @@
#!/bin/sh
-addgroup -S tipidee 2>/dev/null
-adduser -S -D -h / -H -s /sbin/nologin -G tipidee -g tipideelog tipideelog 2>/dev/null
-adduser -S -D -h / -H -s /sbin/nologin -G tipidee -g tipideed tipideed 2>/dev/null
+groupadd -r -- tipidee 2>/dev/null
+useradd -r -d / -M -N -s /sbin/nologin -g tipidee -c tipideelog -- tipideelog 2>/dev/null
+useradd -r -d / -M -N -s /sbin/nologin -g tipidee -c tipideed -- tipideed 2>/dev/null
exit 0