summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2021-07-04 01:51:46 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2021-07-07 17:27:31 -0700
commitb5d2c30d26060d4a55c88c1a665b6e9d95ba1644 (patch)
tree55c1249ddb07cdaed62a4276bb8549ceebecfce8 /pyproject.toml
parent7a9fe189e1df6aa50e6b89109f6e8464a1cd6fdf (diff)
downloadspack-b5d2c30d26060d4a55c88c1a665b6e9d95ba1644.tar.gz
spack-b5d2c30d26060d4a55c88c1a665b6e9d95ba1644.tar.bz2
spack-b5d2c30d26060d4a55c88c1a665b6e9d95ba1644.tar.xz
spack-b5d2c30d26060d4a55c88c1a665b6e9d95ba1644.zip
style: Move isort configuration to pyproject.toml
- [x] Remove flake8-import-order checks, as we only need isort for this - [x] Clean up configuration and requirements
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000000..fc8dd4e428
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,14 @@
+[tool.isort]
+profile = "black"
+sections = [
+ "FUTURE",
+ "STDLIB",
+ "THIRDPARTY",
+ "ARCHSPEC", "LLNL", "FIRSTPARTY",
+ "LOCALFOLDER",
+]
+known_first_party = "spack"
+known_archspec = "archspec"
+known_llnl = "llnl"
+src_paths = "lib"
+honor_noqa = true