summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000000..fc8dd4e428
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,14 @@
+[tool.isort]
+profile = "black"
+sections = [
+ "FUTURE",
+ "STDLIB",
+ "THIRDPARTY",
+ "ARCHSPEC", "LLNL", "FIRSTPARTY",
+ "LOCALFOLDER",
+]
+known_first_party = "spack"
+known_archspec = "archspec"
+known_llnl = "llnl"
+src_paths = "lib"
+honor_noqa = true